Why would anyone bother writing it like that? That just seems like intmain() with extra steps. Like does auto enable some compiler optimisation of the return type that I’m not aware of?
Defining the return type that way can be used when dealing with template sorcery - there’s no use for it here though, not even for readability in any way.
Why would anyone bother writing it like that? That just seems like
int main()
with extra steps. Like does auto enable some compiler optimisation of the return type that I’m not aware of?Defining the return type that way can be used when dealing with template sorcery - there’s no use for it here though, not even for readability in any way.