When I visit the f-droid website, my browser offers me to save a file with a random name. I cannot view the website at all. Any hints?

    • @[email protected]OP
      link
      fedilink
      33 months ago

      Well… just saved one of those files, renamed it to file.html and opened it with the browser. Seems to be the f-droid homepage lacking the css.

      What could it be? That doesn’t happen on any other website.

    • @[email protected]OP
      link
      fedilink
      2
      edit-2
      3 months ago

      The content seems html but the name is something else. On android the suggested filename is downloadfile.bin. creepy.

  • Go-On-A-Steam-Train
    link
    fedilink
    23 months ago

    I don’t know if this useful, but the link works in the UK… I would be interested to hear if you have any luck with it, sorry I can’t be any use beyond this.

    I had the thought of trying a VPN set to other countries if you can, or different DNS settings, but I imagine you already thought of it but can’t think of much else.

    Best of luck with it :)

    • @[email protected]OP
      link
      fedilink
      23 months ago

      I tried to use some webproxy to test other locations and had the same result - only difference is the name offered for the file to download.

      Thanks.

    • @[email protected]OP
      link
      fedilink
      13 months ago

      <drumroll…>Tada!..

      It suddenly is working. I didn’t change a thing.

      @[email protected] suggested I get suspicious about my country or ISP. Should I worry, now?!.. :-(

      Seriously, did the f-droid folks change anything on their end?

      • Go-On-A-Steam-Train
        link
        fedilink
        13 months ago

        That’s bizarre! Glad it’s working, but what the Dickens made it behave so strangely? I imagine it wouldn’t be anything nefarious, especially since its only fdroid, but… Damn that’s odd!

        Glad it solved itself at last :)

    • @[email protected]OP
      link
      fedilink
      2
      edit-2
      3 months ago

      Ahha! With a blank bowser profile directory it works as expected. It has to be HSTS, right? Now, how do I fix this?

  • @[email protected]OP
    link
    fedilink
    2
    edit-2
    3 months ago

    On my desktop, the name is something like <random>.ptrom. Im from Portugal. Could ptrom have anything to do with it?

      • @[email protected]OP
        link
        fedilink
        23 months ago

        Does your ISP or government interfere with your Internet access? When you view the cert, does it show that it was issued by Let’s Encrypt?

        I hope not.

        I can’t inspect any cert. The browser url bar doesn’t show the padlock.